其他分享
首页 > 其他分享> > 1133: 单词个数统计

1133: 单词个数统计

作者:互联网

1133: 单词个数统计

时间限制: 1 Sec  内存限制: 128 MB
提交: 943  解决: 424
[提交] [状态] [讨论版] [命题人:eilene]

题目描述

从键盘输入一行字符,长度小于1000。统计其中单词的个数,各单词以空格分隔,且空格数可以是多个。

输入

输入只有一行句子。仅有空格和英文字母构成 

输出

单词的个数 

样例输入 Copy

stable marriage  problem Consists     of Matching members 

样例输出 Copy

7
#include<stdio.h>

int main()
{
    char str[1001];
    int i,len,count;
    gets(str);
    count=0;
    for(i=0;str[i]!='\0';i++)
    {
        if(str[i]!=' '&&str[i+1]==' ')
        {
            count++;
        }
    }
    len=strlen(str);
    if(str[len-1]!=' ')
    {
        count++;
    }
    printf("%d\n",count);
    return 0;
}

标签:count,1133,个数,len,单词,++,str
来源: https://blog.csdn.net/weixin_55248863/article/details/119155752