编程语言
首页 > 编程语言> > C++9018:2323——分发小球

C++9018:2323——分发小球

作者:互联网

题目来自:http://218.5.5.242:9018/JudgeOnline/problem.php?id=2323

题目描述

把m相同个小球放在n个完全相同的盒子里,允许有的盒子为空,共有几种放法?(20>=m>=n)

输入

m n

样例输入

5 3

样例输出

0 0 5
0 1 4
0 2 3
1 1 3
1 2 2
5

提示

回溯

题目讲解:回溯DFS,非常好用,直接上代码:

#include <bits/stdc++.h>
using namespace std;

int n,m,tot = 0,a[21];
bool vis[21];

void search(int x,int t,int sum){
    if (x > n && sum == m){                // 输出解 
        tot++;
        for (int i = 1;i <= n;i++){
            cout << a[i];
            if (i != n) cout << " ";
        }
        cout << endl;
        return ;
    }
    if (x > n) return ;
    for (int i = t;i <= m - sum;i++){    // 字典序搜索,防止重复 
        vis[i] = true;
        a[x] = i;
        search(x+1,i,sum+i);
        vis[i] = false;
    }
}
int main(){
    memset(vis,false,sizeof(vis));
    cin >> m >> n;
    search(1,0,0);
    cout << tot;                        // 输出个数 
    return 0;
    
}

标签:2323,题目,21,int,样例,C++,9018
来源: https://www.cnblogs.com/linyiweiblog/p/14761167.html