农夫追牛(bfs算法)
作者:互联网
农夫知道一头牛的位置,想要抓住它。农夫和牛都于数轴上 ,农夫起始位于点 N(0<=N<=100000) ,牛位于点 K(0<=K<=100000) 。农夫有两种移动方式: 1、从 X移动到 X-1或X+1 ,每次移动花费一分钟 2、从 X移动到 2*X ,每次移动花费一分钟 假设牛没有意识到农夫的行动,站在原地不动。最少要花多少时间才能抓住牛?
Input
一行: 以空格分隔的两个字母: N 和 K
Output
一行: 农夫抓住牛需要的最少时间,单位分钟
Sample Input
5 17
Sample Output
4
Hint
农夫使用最短时间抓住牛的方案如下: 5-10-9-18-17, 需要4分钟.
刚开始接触bfs算法,还比较生疏,主要是依据列队方式(先进先出),先标记初始位置,该题中农夫有三种选择情况,X-1、X+1、2*X;
然后通过q.push、q.pop等函数对每次农夫的位置进行插入和去除。已经过的点可以用数组标记起来,防止重复,后通过判断最终位置与牛的位置是否重合。
#include"iostream"
#include"algorithm"
#include"cstring"
#include"queue"
using namespace std;
int n,m;
struct state
{
int x,stp;
};
int vst[100005];
bool cheak(state a)
{
if(a.x < 0 || a.x > m+2 || vst[a.x] == 1)
{
return 0;
}
return 1;
}
void bfs(state a)
{
a.stp=0;
queue<state> q;
state now,next;
vst[a.x]=1;
q.push(a);
while(!q.empty())
{
now=q.front();
q.pop();
// cout<<"x= "<<now.x<<endl;
if(now.x==m)
{
cout<<now.stp<<endl;
return ;
}
next.x=now.x*2;
next.stp=now.stp+1;
if(cheak(next))
{
vst[next.x]=1;
q.push(next);
}
next.x=now.x+1;
next.stp=now.stp+1;
if(cheak(next))
{
vst[next.x]=1;
q.push(next);
}
next.x=now.x-1;
next.stp=now.stp+1;
if(cheak(next))
{
vst[next.x]=1;
q.push(next);
}
}
return ;
}
int main()
{
while(cin >> n>> m)
{
if(n >= m)
{
cout<<n-m<<endl;
continue;
}
state a;
a.x=n;
memset(vst,0,sizeof(vst));
bfs(a);
}
return 0;
}
标签:vst,int,追牛,bfs,state,include,农夫 来源: https://blog.csdn.net/qq_44996964/article/details/98878996