题目 1035: [编程入门]自定义函数之字符类型统计
作者:互联网
题目描述
编写一函数,由实参传来一个字符串,统计此字符串中字母、数字、空格和其它字符的个数,在主函数中输入字符串以及输出上述结果。
只要结果,别输出什么提示信息。
输入
一行字符串
输出
统计数据,4个数字,空格分开。
样例输入
!@#$%^QWERT 1234567
样例输出
5 7 4 6
代码
import java.util.Scanner;
public class Main {//主函数
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
String str = scan.nextLine();
num(str);
}
public static void num(String str){//num函数执行具体方法
//定义四个变量分别接收字符串中各符号的个数
int num1=0;//字母
int num2=0;//数字
int num3=0;//空格
int num4=0;//其他
for(int i=0;i<str.length();i++) {
if(('A'<=str.charAt(i)&&str.charAt(i)<='Z')||('a'<=str.charAt(i)&&str.charAt(i)<='z')){
//注意字符大小写
num1++;
}else if('0'<=str.charAt(i)&&str.charAt(i)<='9') {
//数字一定要带'',才是以字符格式遍历
num2++;
}else if(str.charAt(i)==' '){
//空格
num3++;
}else{
//其他
num4++;
}
}
System.out.print(num1+" "+num2+" "+num3+" "+num4+"\n");
}
}
扩展
- 可以直接直接使用str.charAt(i)来获取字符串中数字进行遍历。
- 注意在遍历大小写时为大写判断和小写判断都加上括号()。
- 遍历的数字是字符要加上‘ ’。【注: ’ '字符格式,“ ”字符串格式】
标签:字符,遍历,自定义,int,编程,++,str,字符串,1035 来源: https://blog.csdn.net/qq_46590675/article/details/122490744